We try to make sure that everyone can play at MrQ, so if you want to play you'll need the latest (the last of couple versions):
• Edge
• Firefox
• Chrome on desktop and Android
• Safari on OSX

If you're playing on your iPhone 📱, we support iOS 10.3 and higher

Did this answer your question?